Jibble

Author Topic: Expression Speech Style Module Error  (Read 843 times)

ChronicFreshman

  • Posts: 5
Expression Speech Style Module Error
« on: 12 Apr 2015, 20:33 »
Hello,

I'm just getting started on the skeleton of a game and I ran into a problem with Shade's Expression Speech Style module. I imported the script and followed the included directions. But when I try to play the game, this error pops up:

"Vairable 'Speech' is already defined."

From what I understand, this means that the the variable "Speech" is already being used in the original script, but I'm not sure how to fix the issue and it isn't addressed in the module instructions so I take it it's probably something pretty obvious.

Sorry in advance if this is a question better posted on the module's thread, it just seemed like a very beginner issue.

Thanks!


Crimson Wizard

  • Posts: 8,794
    • Best Innovation Award Winner 2013, for spearheading the AGS 3.3.0 project
    • Lifetime Achievement Award Winner
    • Crimson Wizard worked on a game that won an AGS Award!
    •  
    • Crimson Wizard worked on a game that was nominated for an AGS Award!
Re: Expression Speech Style Module Error
« Reply #1 on: 13 Apr 2015, 11:31 »
There's a new Speech class introduced in AGS 3.3.0. The script module you were importing could be made for older version of AGS and therefore using its own "speech" variable or class, that conflicts with new AGS feature.

The script module should be modified to resolve this conflict.

Monsieur OUXX

  • Posts: 3,553
  • Mittens Half Initiate
    • I can help with proof reading
    • I can help with translating
    • I can help with voice acting
Re: Expression Speech Style Module Error
« Reply #2 on: 13 Apr 2015, 16:11 »
Additionally to what CW said :
- Either it's a variable or struct that is already named "Speech" in the module --> In that case just do a full-text research and replace "Speech" with "MySpeech" or whatever
- Or it's a GUI or sound or view that is already named "gSpeech" or "aSpeech" or something. It means they're not declared in the script/modules text, but instead somewhere in the AGS Editor --> In that case, there's a chance that AGS automatically created a symbol called "SPEECH" or something. Even if it doesn't appear in the scripts, don't let yourself be fooled. For example, think that renaming the speech gui from "gSpeech" to "gMySpeech" might fix the issue.
 

ChronicFreshman

  • Posts: 5
Re: Expression Speech Style Module Error
« Reply #3 on: 13 Apr 2015, 22:47 »
Thank you both for the in-depth advice. This sounds like it might be effective. I'll give it a shot!

my2k

  • Posts: 16
Re: Expression Speech Style Module Error
« Reply #4 on: 12 Apr 2016, 04:20 »
edit; terribly sorry for bumping an old thread. I've managed to fix my problem, sorry again...
« Last Edit: 12 Apr 2016, 06:03 by my2k »